summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBambang Catur Pamungkas2018-12-19 11:27:20 +0700
committerBambang Catur Pamungkas2018-12-19 11:28:16 +0700
commit4f48887d929093350d590b017c1025ec5669f9ac (patch)
treeaf88bfc264b4e04dd0eba888145e53c7af9acd99 /PKGBUILD
downloadaur-4f48887d929093350d590b017c1025ec5669f9ac.tar.gz
v1.37.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72e00bc3f70b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Bambang Catur Pamungkas <bambangcaturz@gmail.com>
+
+_npmname='@sentry/cli'
+pkgname=sentry-cli
+pkgver=1.37.1
+pkgrel=1
+pkgdesc="A command line utility to work with Sentry"
+arch=('i686' 'x86_64')
+url="https://docs.sentry.io/cli/"
+license=('BSD')
+depends=('nodejs' 'npm')
+optdepends=()
+source=(http://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz)
+noextract=($_npmname-$pkgver.tgz)
+sha256sums=('72d359529b7cb5132fd7167be26b0b6095331121084c615b7501c61f76038e40')
+
+package() {
+ cd $srcdir
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
+ # remove reference to $pkgdir
+ # see: https://github.com/npm/npm/issues/10393
+ find . -name "package.json" -type f | xargs sed -i -e '/_where/d'
+}
+
+# vim:set ts=2 sw=2 et: