summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Giles2015-07-23 21:25:51 +0200
committerOliver Giles2015-07-23 21:25:51 +0200
commit93e46897e7e66998b7716c22d926c1ee1079bbc1 (patch)
treec1103afb7d22f63f01e257c1a0f3e54a6e3a643e /PKGBUILD
downloadaur-93e46897e7e66998b7716c22d926c1ee1079bbc1.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..173b8cf0462a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Oliver Giles <web ohwg net>
+pkgname=sequeljoe
+pkgver=0.4
+pkgrel=1
+pkgdesc="SQL database administration tool"
+arch=('i686' 'x86_64')
+url='http://sequeljoe.ohwg.net'
+license=('GPL3')
+groups=()
+depends=('qt5-base' 'libssh2' 'libnotify')
+optdepends=(
+ 'libmariadbclient: MySQL/MariaDB support'
+ 'sqlite: sqlite support'
+ 'postgresql-libs: PostgreSQL support (experimental)'
+)
+makedepends=('cmake')
+options=('strip')
+source=("https://github.com/ohwgiles/sequeljoe/archive/$pkgver.zip")
+md5sums=('a715fb01f3f03d16bbaa5a695c7db299')
+
+build() {
+ cd $pkgname-$pkgver
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release src
+ make -j4
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+