summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2021-12-19 22:36:07 +0100
committerFabioLolix2021-12-19 22:36:07 +0100
commitd35740d4645d271c2eeca974b198d5e116486034 (patch)
treeab809dc7940dbfe0d8dd507ede27972c8557e259 /PKGBUILD
parentd9b2387f1e792824a66d895d28d5d81707145e69 (diff)
downloadaur-serpent-browser.tar.gz
v21.12.14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 725dd3e9c319..007b2948fcd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,30 @@
# Contributor: Frederic Bezies <fredbezies at gmail dot com>
pkgname=serpent-browser
-pkgver=2021.07.19
+pkgver=2021.12.14
pkgrel=1
pkgdesc="Unbranded version of Basilisk web browser"
arch=(x86_64 i686 pentium4 arm armv6h armv7h aarch64)
url="https://www.basilisk-browser.org/"
license=(MPL GPL LGPL)
depends=(gtk2 gtk3 libxt mailcap nss alsa-lib icu ttf-font libpulse)
-makedepends=(git unzip zip python2 yasm mesa autoconf2.13 gcc10)
+makedepends=(unzip zip python2 yasm mesa autoconf2.13 gcc10)
optdepends=('hunspell: spell checker and morphological analyzer'
'hyphen: library for hyphenation and justification'
'ffmpeg: record, convert, and stream audio and video')
provides=(basilisk)
conflicts=(basilisk)
options=(!emptydirs !makeflags)
-source=("${pkgname%-git}::git+https://repo.palemoon.org/MoonchildProductions/Basilisk.git#tag=v${pkgver}"
- serpent-browser.desktop
- "git+https://repo.palemoon.org/MoonchildProductions/UXP.git")
-sha256sums=('SKIP'
- 'ba1502352e069f6945519228ef776e4c2eadaf5165132ec9edcbe71135b7c848'
- 'SKIP')
+source=("http://archive.palemoon.org/source/basilisk-${pkgver}-source.tar.xz"
+ 'serpent-browser.desktop') #{,.sig}
+sha256sums=('cf5305a6d232e6a8493be521fa45b110edf9d911f04f029dd4b433a726a84e49'
+ 'ba1502352e069f6945519228ef776e4c2eadaf5165132ec9edcbe71135b7c848')
+
+# (the public key 3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC is not trusted)
export CC=/usr/bin/gcc-10 CXX=/usr/bin/g++-10
prepare() {
- cd "${srcdir}/${pkgname%-git}"
-
- git submodule init
- git config 'submodule.platform.url' "${srcdir}/UXP"
- git submodule update
-
cat > .mozconfig << EOF
mk_add_options AUTOCLOBBER=1
@@ -66,13 +60,11 @@ EOF
}
build() {
- cd "${srcdir}/${pkgname%-git}"
make -f client.mk build
}
package() {
- cd "${srcdir}/${pkgname%-git}"
make -f client.mk DESTDIR="$pkgdir" install