summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2017-01-23 20:13:09 +0100
committerNicolas Iooss2017-01-23 20:13:09 +0100
commit3a67ea6522f46f0944cc0e9616a2b5a7f57de2a0 (patch)
tree19f4459a76404aded6019956fce4bd4e66ebaa2c /PKGBUILD
parentebc663b302c39ff453c124c03efede70af9096d5 (diff)
downloadaur-3a67ea6522f46f0944cc0e9616a2b5a7f57de2a0.tar.gz
setools: fix build with flex 2.6.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 532021488023..bfe2f0a875df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@
pkgname=setools
pkgver=4.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Policy analysis tools for SELinux"
groups=('selinux')
arch=('i686' 'x86_64')
@@ -38,14 +38,14 @@ sha256sums=('4c2049877f2f68e4485b72bc280fe20127b49a019169a2cf1d8295c908bdcdfe')
prepare() {
cd "${pkgname}-${pkgver}"
- # Flex 2.6.1 generates C code which causes -Wsign-compare to trigger:
- # libqpol/policy_scan.c: In function ‘yy_scan_bytes’:
- # libqpol/policy_scan.c:3254:17: warning: comparison between signed and
- # unsigned integer expressions [-Wsign-compare]
- # for ( i = 0; i < _yybytes_len; ++i )
- # ^
+ # Flex 2.6.3 generates C code which causes -Werror to trigger:
+ # libqpol/policy_scan.c:398:0: error: "yywrap" redefined [-Werror]
+ # #define yywrap() (/*CONSTCOND*/1)
+ # libqpol/policy_scan.c:74:0: note: this is the location of the previous definition
+ # #define yywrap yywrap
+ # This a a bug in Flex, https://github.com/westes/flex/issues/155
# Do not make the build fail because of this
- sed -e "s/\('-Werror',\)/\1 '-Wno-error=sign-compare',/" -i setup.py
+ sed -e "s/'-Werror',//" -i setup.py
}
build() {