summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDang Mai2019-04-01 03:16:44 +0000
committerDang Mai2019-04-01 03:16:44 +0000
commit8c1788fbe09833adcec7fe0ea67e2fe2696d8b48 (patch)
tree45a9b3040989aceabdfeb1b00b0784cd68da2bbd /PKGBUILD
parent85d97a4ea0a343fe04750b2afc0eb1b40a7c5550 (diff)
downloadaur-8c1788fbe09833adcec7fe0ea67e2fe2696d8b48.tar.gz
Updated to 7.1.4_79f97a7df8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 6 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de948e5c8979..60ee9870a70d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,27 @@
# Maintainer: Dang Mai <contact at dangmai dot net>
pkgname=sfdx-cli
-pkgver="6.56.0_e3fd846a1f"
+pkgver="7.1.4_79f97a7df8"
pkgrel=1
_dirname="${pkgname}-v${pkgver}"
pkgdesc="a tool for creating and managing Salesforce DX projects from the command line"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://developer.salesforce.com/tools/sfdxcli"
license=('unknown')
optdepends=('gnome-keyring: saving default credentials')
provides=('sfdx-cli')
options=(!strip)
conflicts=()
-source_i686=("https://developer.salesforce.com/media/salesforce-cli/sfdx-cli/channels/stable/sfdx-cli-v6.56.0-e3fd846a1f-linux-x86.tar.xz")
-source_x86_64=("https://developer.salesforce.com/media/salesforce-cli/sfdx-cli/channels/stable/sfdx-cli-v6.56.0-e3fd846a1f-linux-x64.tar.xz")
+source_x86_64=("https://developer.salesforce.com/media/salesforce-cli/sfdx-cli/channels/stable/sfdx-cli-v7.1.4-79f97a7df8-linux-x64.tar.xz")
package() {
- _arch=""
- case $CARCH in
- "x86_64")
- _arch="x64"
- ;;
- "i686")
- _arch="x86"
- ;;
- esac
-
+ _arch="x64"
cd "${srcdir}"
install -dm 755 "${pkgdir}"/opt
install -dm 755 "${pkgdir}"/usr/bin
- sfdx_dir="sfdx-cli-v"6.56.0-e3fd846a1f"-linux-${_arch}"
+ sfdx_dir="sfdx-cli-v"7.1.4-79f97a7df8"-linux-${_arch}"
cp -a "${sfdx_dir}" "${pkgdir}"/opt/sfdx-cli
ln -s /opt/sfdx-cli/bin/sfdx "${pkgdir}"/usr/bin/sfdx
}
-sha256sums_i686=("3c64f590e7772a31338f093d119250c54e7a6574c531df13160961a5c6bde587")
-sha256sums_x86_64=("5a8091e1172245392e889cf6c17c1b6edb6ccbf5d599901a782d7ee0df87e3b0")
+sha256sums_x86_64=("c8c71571e50eb21c7ff537fe9ab7f42fc0a4333bf1dc02100256d48f67483e6b")