summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJerome Rose2015-08-12 01:42:26 +0000
committerJerome Rose2015-08-12 01:42:26 +0000
commitc569acd6ec3ddad38564ea7c6878bd051ba16391 (patch)
treeb5f259b54b30b571f0d8a7d29865fec429420c90 /PKGBUILD
downloadaur-c569acd6ec3ddad38564ea7c6878bd051ba16391.tar.gz
ver 1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8983effa92d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jerome Rose <jrose[dot]pub[at]gmail[dot]com>
+pkgname=sfemovie-git
+pkgver=1
+pkgrel=1
+pkgdesc="sfeMovie is a simple C++ library that lets you play movies in SFML based applications. It relies on FFmpeg to read medias and remains consistent with SFML's naming conventions."
+url="https://github.com/Yalir/sfeMovie"
+arch=('x86_64' 'i686')
+license=('LGPLv2.1')
+depends=('sfml' 'ffmpeg')
+optdepends=()
+makedepends=('git' 'cmake' 'yasm')
+conflicts=()
+replaces=()
+backup=()
+#install='foo.install'
+source=()
+md5sums=()
+_pkgnameshort=sfeMovie
+_gitsource=https://github.com/Yalir/sfeMovie.git
+_gitbranch=master
+
+build() {
+ cd "${srcdir}"
+ git clone $_gitsource
+ cd "${srcdir}/${_pkgnameshort}"
+ git checkout $_gitbranch
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLINK_AGAINST_INTERNAL_FFMPEG:BOOL=FALSE
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgnameshort}"
+ make DESTDIR="${pkgdir}" install
+}