summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredtide2023-05-06 12:55:13 +0200
committerredtide2023-05-06 12:55:13 +0200
commit5b78d39c48330028f0fe274348fb7a16bc100ee7 (patch)
treedbb61f8bb27c73d71500e76fdc9900b83cb6041b /PKGBUILD
parentcc28993f2bc7ff1f1aa840a577de9377d73f6319 (diff)
downloadaur-5b78d39c48330028f0fe274348fb7a16bc100ee7.tar.gz
Source used git submodules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 47 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a3343b35327..92ce7ecdac81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,14 +27,45 @@ makedepends=(
git
jack
lv2
+ lv2-host
+ pd
# simde
# vst3sdk
xcb-util-keysyms
)
checkdepends=(lv2lint catch2)
-source=("$_pkgname"::"git+https://github.com/sfztools/sfizz#branch=develop")
-sha512sums=('SKIP')
-b2sums=('SKIP')
+source=(
+ $_pkgname::git+https://github.com/sfztools/sfizz#branch=develop
+ git+https://github.com/steinbergmedia/vst3_base
+ git+https://github.com/steinbergmedia/vst3_pluginterfaces
+ git+https://github.com/steinbergmedia/vst3_public_sdk
+ git+https://github.com/sfztools/vstgui
+ git+https://github.com/simd-everywhere/simde
+ git+https://github.com/mackron/dr_libs
+ git+https://github.com/sfztools/stb_vorbis
+ git+https://github.com/sfztools/libaiff
+ git+https://github.com/sfztools/sfzt_auwrapper
+)
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
_common_depends=(
abseil-cpp
@@ -76,7 +107,19 @@ pkgver() {
prepare() {
cd $_pkgname
- git submodule update --init --recursive
+ git submodule init
+ # Temporary
+ git config submodule.plugins.vst.external.VST_SDK.VST3_SDK.base ../base
+ git config submodule.plugins.vst.external.VST_SDK.VST3_SDK.pluginterfaces ../pluginterfaces
+ git config submodule.plugins.vst.external.VST_SDK.VST3_SDK.public.sdk ../public.sdk
+ git config submodule.plugins.editor.external.vstgui4 ../vstgui4
+ git config submodule.external.simde.url ../simde
+
+ git config submodule.external.st_audiofile.thirdparty.dr_libs.url ../dr_libs
+ git config submodule.external.st_audiofile.thirdparty.stb_vorbis.url ../stb_vorbis
+ git config submodule.external.st_audiofile.thirdparty.libaiff.url ../libaiff
+ git config submodule.plugins.vst.external.sfzt_auwrapper.url ../sfzt_auwrapper
+ git submodule update
# symlink tests data to top-level location so that tests can get to them (we build out of tree)
ln -svf "$srcdir"/$_pkgname/tests "$srcdir"/tests