summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredtide2021-04-17 02:44:07 +0200
committerredtide2021-04-17 02:44:07 +0200
commitb05b0e09dff12fb3ed8ce218edfce7044fa0c5db (patch)
tree2079dfaf907c3fc73b5afaa8d14f33d66976f212 /PKGBUILD
parent614e6790b2718560eafba919550500da3ef9dfcf (diff)
downloadaur-b05b0e09dff12fb3ed8ce218edfce7044fa0c5db.tar.gz
Bump version, default release build, libsndfile removal
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18ffb559f0f1..bd41136a0445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,15 @@
_pkgname="sfizz"
pkgname="${_pkgname}-git"
-pkgver=r3555.343350ad
+pkgver=r3599.5da137a8
pkgrel=1
pkgdesc="SFZ library and LV2 plugin"
url="https://sfz.tools/sfizz"
arch=('x86_64')
license=('custom:BSD-2-Clause' 'custom:ISC')
makedepends=('git' 'cmake')
-depends=('libsndfile' 'jack' 'libx11' 'libxcb' 'xcb-util' 'xcb-util-cursor'
- 'xcb-util-keysyms' 'libxkbcommon' 'libxkbcommon-x11' 'fontconfig' 'cairo'
- 'freetype2' 'pango' 'zenity')
+depends=('jack' 'libx11' 'libxcb' 'xcb-util' 'xcb-util-cursor' 'xcb-util-keysyms'
+ 'libxkbcommon' 'libxkbcommon-x11' 'fontconfig' 'cairo' 'freetype2' 'pango' 'zenity')
provides=("${_pkgname}" "lib${_pkgname}.so")
conflicts=("${_pkgname}")
source=("$pkgname"::"git+https://github.com/sfztools/sfizz#branch=develop")
@@ -28,7 +27,7 @@ prepare() {
build() {
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr" -DSFIZZ_JACK=ON -DSFIZZ_LV2=ON -DSFIZZ_VST=ON "${srcdir}/${pkgname}"
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr" "${srcdir}/${pkgname}"
cmake --build . --target all
}
package() {