summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorafify2022-01-29 00:08:09 +0300
committerafify2022-01-29 00:08:09 +0300
commitada5205ee086e394f1c21d70bdfcfd0b6dcdf30a (patch)
treee82edf2ba71f72356278f87fbb8ef3eced4cf1f7 /PKGBUILD
downloadaur-ada5205ee086e394f1c21d70bdfcfd0b6dcdf30a.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3259cc80b582
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Afify <hassan[ap]afify[dot]dev>
+pkgname=sfm
+pkgver=0.4
+pkgrel=1
+epoch=
+pkgdesc="sfm is a simple file manager for unix-like systems"
+arch=('x86_64')
+url="https://git.afify.dev/sfm"
+license=('ISC')
+depends=('make' 'clang')
+groups=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://git.afify.dev/sfm/releases/$pkgname-v$pkgver.tar.gz")
+sha256sums=("ae0f610c29246aeb6ca1e1bc40868820b2fc59ee7d27c57fe03f97f4cd316344")
+noextract=()
+validpgpkeys=()
+
+build() {
+ cd "$srcdir/$pkgname-v$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-v$pkgver"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}