summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroi_wtf2018-03-27 18:03:45 +0200
committeroi_wtf2018-03-27 18:03:45 +0200
commit1bcfa5b1c744a7c35a2009cecae1d5f30351d052 (patch)
tree099bca0afadd981ed82c0785814fe78f9d5f1845 /PKGBUILD
parentbe596c816592df40ec5bc416a204fc1d0655ea6b (diff)
downloadaur-1bcfa5b1c744a7c35a2009cecae1d5f30351d052.tar.gz
remove unneccessary patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dda89172335b..982571481437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: oi_wtf <brainpower at mailbox dot org>
pkgname=sfml-git
-pkgver=2.4.0.r37.g858c9ce9
+pkgver=2.4.0.r126.gfc655f52
pkgrel=1
pkgdesc="A simple, fast, cross-platform, and object-oriented multimedia API"
arch=('i686' 'x86_64')
@@ -14,10 +14,8 @@ conflicts=('sfml')
replaces=('sfml')
options=('debug')
-source=("git+https://github.com/SFML/SFML.git"
- "0001-fix_cmake_module_install_path.patch")
-sha256sums=('SKIP'
- 'c0be2636b1d342f636f2587e043dbfa8becdd8d9c65044cf7749ab4b2c81eb47')
+source=("git+https://github.com/SFML/SFML.git")
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/SFML"
@@ -26,7 +24,6 @@ pkgver() {
prepare() {
cd "$srcdir/SFML"
- patch -p0 -i "$srcdir/0001-fix_cmake_module_install_path.patch"
}
build() {
@@ -34,8 +31,9 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX=/usr . \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
- -DBUILD_DOC=true \
- -DBUILD_EXAMPLES=false
+ -DSFML_BUILD_DOC=false \ # switch to true if you need offline documentation
+ -DSFML_BUILD_EXAMPLES=false \
+ -DSFML_INSTALL_PKGCONFIG_FILES=true # prints a warning if pkg-config not supported
make
make doc
}