summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaetan Bisson2018-12-10 11:21:58 -1000
committerGaetan Bisson2018-12-10 11:21:58 -1000
commit8e5df6a77144251e63aea637422b9625709848fd (patch)
treee4b7a2856c5a5a10a2b439aecf9f0d9ecaa2275b /PKGBUILD
downloadaur-8e5df6a77144251e63aea637422b9625709848fd.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10bbacd34b1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=sgfutils
+pkgver=0.25
+pkgrel=1
+pkgdesc='Collection of command line utilities that help working with SGF files'
+url='https://homepages.cwi.nl/~aeb/go/sgfutils/'
+license=('GPL')
+arch=('x86_64')
+depends=('openssl')
+source=("${url}${pkgname}-${pkgver}.tgz")
+sha256sums=('4b26b321fbe255722f1d7e57233614da89a4da5bab031ae4ef7118ae3c7436a2')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed 's/^CFLAGS=/CFLAGS+=/' -i Makefile
+ make all
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ls | while read i; do
+ if [[ ! -d "$i" && -x "$i" ]]; then
+ install -D "$i" "${pkgdir}/usr/bin/$i"
+ fi
+ done
+
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -a html/* "${pkgdir}/usr/share/doc/${pkgname}"
+}