summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDarks2021-07-15 08:59:35 +0200
committerDarks2021-07-15 08:59:35 +0200
commitd6ba6c7b0cb080bfc204f05fa5111ea8bf349b3c (patch)
tree0c287656d31a34235022165f78bf2b1fb9695f9b /PKGBUILD
parentcb7a810e757d7954169060e2520a191d97e5c0d4 (diff)
downloadaur-d6ba6c7b0cb080bfc204f05fa5111ea8bf349b3c.tar.gz
Disable makepkg.conf CPPFLAGS as it triggers build errors.
This solution looks better than disabling all flags set in makepkg.conf
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0e3ac4addd4..a93c717abb23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_target="sh-elf"
pkgname=${_target}-binutils-casio
pkgver=2.36.1
-pkgrel=4
+pkgrel=5
pkgdesc="GNU binary utilities for the Casio calculators SuperH processors."
arch=('i686' 'x86_64')
url='https://www.gnu.org/software/binutils/'
license=('GPL')
depends=('binutils' 'flex' 'zlib')
makedepends=('gcc')
-options=('!buildflags' '!emptydirs' '!libtool')
+options=('!emptydirs' '!libtool')
source=("https://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2")
sha256sums=('5b4bd2e79e30ce8db0abd76dd2c2eae14a94ce212cfc59d3c37d23e24bc6d7a3')
@@ -22,6 +22,7 @@ prepare() {
}
build() {
+ export CPPFLAGS=""
cd "${srcdir}/binutils-${pkgver}/binutils-build"
../configure \
--prefix=/usr \