summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLouise2019-06-11 00:04:14 +0200
committerLouise2019-06-11 00:04:14 +0200
commit59d781f2c2571aa042a6f391770222b64f4988ab (patch)
tree48cb5b88b8906a131070c8b0d333a24eadb0691d /PKGBUILD
parent3b487016342f967715147473ebf1666d46d5aff2 (diff)
downloadaur-59d781f2c2571aa042a6f391770222b64f4988ab.tar.gz
Updated to GCC 9.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce8923025b32..c07e24972e7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,23 @@
_target="sh3eb-elf"
pkgname=${_target}-gcc
-pkgver=8.2.1+20181127
+pkgver=9.1.0
pkgrel=1
+_islver=0.19
pkgdesc="The GNU Compiler Collection for the ${_target} target."
arch=(i686 x86_64)
license=('GPL' 'LGPL')
url="http://gcc.gnu.org"
depends=("${_target}-binutils" 'libmpc' 'elfutils')
options=('staticlibs' '!buildflags' '!libtool' '!emptydirs' 'zipman' 'docs' '!strip')
-source=(https://sources.archlinux.org/other/gcc/gcc-${pkgver/+/-}.tar.xz)
-sha256sums=('6f64ffda2839e96a8551b767bf4f92be4e7a09377ea40058355b4eeb13bc3800')
+source=("http://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz"
+ "http://isl.gforge.inria.fr/isl-${_islver}.tar.xz")
+sha256sums=('79a66834e96a6050d8fe78db2c3b32fb285b230b855d0a66288235bc04b327a0'
+ '6d6c1aa00e2a6dfc509fa46d9a9dbe93af0c451e196a670577a148feecf6b8a5')
prepare() {
cd "${srcdir}/gcc-${pkgver/+/-}"
+ ln -s ../isl-$_islver isl
[[ -d gcc-build ]] && rm -rf gcc-build
mkdir gcc-build