summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonne Haß2020-06-16 21:04:21 +0000
committerJonne Haß2020-06-18 21:21:02 +0200
commitfc82ae89bafa975bd17c5715db4ae191a283bdba (patch)
tree91bb904b6d34485c4665a03a0933e3a06ce9576f /PKGBUILD
parent2d2dacba90cec923638c1d18c5ac97a10a25cb35 (diff)
downloadaur-fc82ae89bafa975bd17c5715db4ae191a283bdba.tar.gz
shards-git: fix and enable aarch64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 800f599ede77..99f1473b5420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jonne Haß <me@jhass.eu>
pkgname=shards-git
-pkgver=v0.5.3.r0.geaaced6
+pkgver=v0.11.1.r0.g3b7d490
pkgrel=1
pkgdesc="The package manager for the Crystal language (git version)"
-arch=('i686' 'x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/ysbaddaden/shards"
license=('Apache')
conflicts=('shards')
provides=('shards')
-depends=('libyaml' 'git' 'libpcl' 'libevent' 'gc')
+depends=('libyaml' 'git' 'libevent' 'gc')
makedepends=('crystal')
source=("git+https://github.com/ysbaddaden/shards.git")
@@ -23,7 +23,7 @@ pkgver() {
build() {
cd "${pkgname/-git/}"
- crystal build --release -o bin/shards src/shards.cr
+ make CRYSTAL_OPTS="--release"
}
check() {
@@ -34,10 +34,8 @@ check() {
package() {
cd "${pkgname/-git/}"
-
- install -Dm755 bin/shards "$pkgdir/usr/bin/shards"
- install -Dm644 src/man/shards.1 "$pkgdir/usr/share/man/man1/shards.1"
- install -Dm644 src/man/shard.yml.5 "$pkgdir/usr/share/man/man5/shard.yml.5"
+
+ make install PREFIX="$pkgdir/usr"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
sha256sums=('SKIP')