summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRecolic Keghart2021-10-13 02:18:21 +0800
committerRecolic Keghart2021-10-13 02:18:21 +0800
commit5072b8a7895dbd0aa125df5e1065a15c6fb3bfd2 (patch)
treebc395eed788a50d52b64bcf560647a3ce1c33cc8 /PKGBUILD
downloadaur-5072b8a7895dbd0aa125df5e1065a15c6fb3bfd2.tar.gz
sync, for commit 75dba817df04f273c890653396ceb22d80858e95 in original repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6090748e4425
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Recolic Keghart <root@recolic.net>
+# Original repo: https://git.recolic.net/root/shared-bootdir-helper
+# Mirror: https://github.com/recolic/shared-bootdir-helper
+
+pkgname=shared-bootdir-helper
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Allow multiple linux installations to share the same /boot directory, even with different kernel parameters. "
+url="https://git.recolic.net/root/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("bash" "sed" "grep" "mkinitcpio")
+install="$pkgname.install"
+backup=(etc/shared-bootdir-helper-multi-kparam.cfg)
+source=(
+ "$pkgname::git+https://git.recolic.net/root/$pkgname.git"
+)
+validpgpkeys=("6861D89984E7887F0FFE6E08C344D5EAE3933636")
+sha256sums=(
+ "SKIP"
+)
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/etc" "$pkgdir/usr/bin" "$pkgdir/usr/share/libalpm/hooks" "$pkgdir/usr/share/libalpm/scripts" &&
+ mv src/*.cfg "$pkgdir/etc/" &&
+ mv src/hook-*.sh "$pkgdir/usr/share/libalpm/scripts/" &&
+ mv src/*.sh "$pkgdir/usr/bin/" &&
+ mv src/*.hook "$pkgdir/usr/share/libalpm/hooks/" ||
+ return $?
+}
+