summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2022-11-04 15:03:05 -0400
committerKevin MacMartin2022-11-04 15:03:05 -0400
commitf27eb6dd3c81b88833db3d1bb3cb711d722d6191 (patch)
treefa03b5c0c897c55eef47f18de5d71e66d7cd7cbd /PKGBUILD
parent8f181519560f052fbc9644aa76f0c80122af933e (diff)
downloadaur-f27eb6dd3c81b88833db3d1bb3cb711d722d6191.tar.gz
Remove the fix-build patch, use jdk17 to compile, and update to 5932v1.4.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 352930fe7bff..791512330877 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,27 +5,25 @@
_pkgname=shattered-pixel-dungeon
pkgname=$_pkgname-git
-pkgver=5895v1.4.1
+pkgver=5932v1.4.3
pkgrel=1
pkgdesc='Shattered fork of the popular rogue-like game'
url='https://shatteredpixel.com'
license=('GPL3')
depends=('java-runtime' 'bash')
-makedepends=('git' 'java-environment')
+makedepends=('git' 'jdk17-openjdk')
arch=('any')
source=(
"$_pkgname::git+https://github.com/00-Evan/shattered-pixel-dungeon.git"
"$_pkgname.sh"
"$_pkgname.desktop"
- 'fix-build.patch'
)
sha512sums=(
'SKIP'
'88814d1f33eea6bd5656d3ca731ed5a6cfce10ecdae24012252c5b32c4b194ec75fb0e22cac70897802679086c6a32e210d52933ec45ca94ff350ac4ad7c266e'
'204a7bcedbbc14bdad6586e4b759b326191a7fd2c344dadc7032495d4caa5fe32edac4118d7294229a6fe24f6684416fff37e260bbc9dde9e50846a03ba77db8'
- '2abddbb6e8e46045c406e3728cf0a616db279d807a129b860d86e692be97943052e0dffb9e30b051c0a99db9a13629913f411f887fe1a02b04fa9b2bf54d3d26'
)
pkgver() {
@@ -38,14 +36,12 @@ prepare() {
# Make the gradlew script executable
chmod 755 gradlew
-
- # Fix the build
- # patch -p1 < ../fix-build.patch
}
build() {
cd $_pkgname
unset _JAVA_OPTIONS
+ export PATH=/usr/lib/jvm/java-17-openjdk/bin/:$PATH
GRADLE_USER_HOME="$srcdir" ./gradlew desktop:release
}