summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMagnus Boman2020-05-02 16:41:35 +0200
committerMagnus Boman2020-05-02 16:41:35 +0200
commit08e78dcf58dfcb783153e1ef919ef174f0f9fc14 (patch)
treef59cf2ec93c544e32a3f3981bcbce5248d9d15bb /PKGBUILD
parent1938722a7631b3ce06e5a23b9b1ab7e67b3342a5 (diff)
downloadaur-08e78dcf58dfcb783153e1ef919ef174f0f9fc14.tar.gz
Renamed from shellcheck-static and updated to 0.7.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 16 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9b1c1cc117e..82f06d004b7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,25 @@
-# Maintainer: Eric Berquist <eric DOT berquist AT gmail DOT com>
+# Maintainer: katt <magunasu.b97@gmail.com>
_pkgname=shellcheck
-pkgname="${_pkgname}-bin"
-pkgver=0.3.7
+pkgname="$_pkgname-bin"
+pkgver=0.7.1
pkgrel=1
-pkgdesc="A shell script static analysis tool: Ubuntu binary build"
-arch=("i686" "x86_64")
-url="http://www.shellcheck.net/"
+url='https://shellcheck.net'
+pkgdesc='Shell script analysis tool (binary release)'
license=('AGPL3')
-depends=("gmp" "libffi")
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-source_i686=("http://archive.ubuntu.com/ubuntu/pool/universe/s/${_pkgname}/${_pkgname}_${pkgver}-1_i386.deb")
-source_x86_64=("http://archive.ubuntu.com/ubuntu/pool/universe/s/${_pkgname}/${_pkgname}_${pkgver}-1_amd64.deb")
-md5sums_i686=("470c55b1d2e01d798da52b7047f9910e")
-md5sums_x86_64=("8cd0fcf8c7eade51890b15e5b05cfc98")
+arch=('x86_64' 'armv6h' 'aarch64')
+conflicts=("$_pkgname")
+provides=("$_pkgname")
-package() {
- cd "${srcdir}"
-
- bsdtar -xf data.tar.xz
+source_x86_64=("https://github.com/koalaman/$_pkgname/releases/download/v$pkgver/$_pkgname-v$pkgver.linux.x86_64.tar.xz")
+source_armv6h=("https://github.com/koalaman/$_pkgname/releases/download/v$pkgver/$_pkgname-v$pkgver.linux.armv6hf.tar.xz")
+source_aarch64=("https://github.com/koalaman/$_pkgname/releases/download/v$pkgver/$_pkgname-v$pkgver.linux.aarch64.tar.xz")
- # binary
- install -D -m 755 \
- "${srcdir}"/usr/bin/"${_pkgname}" \
- "${pkgdir}"/usr/bin/"${_pkgname}"
+sha512sums_x86_64=('beca3d7819a6bdcfbd044576df4fc284053b48f468b2f03428fe66f4ceb2c05d9b5411357fa15003cb0311406c255084cf7283a3b8fce644c340c2f6aa910b9f')
+sha512sums_armv6h=('7d8fd04a7b3b7291b3f6236ad15ee1d06a893b7e878b944e22dad1c16d627b583d72d489cccbdfbb4915f85d456e3c72a39ec83c98e31a901c104c8f59f59bf7')
+sha512sums_aarch64=('0068c11477aa7166d0940934ad0e8e243788e1626f080cd57974b03bc4c75581918e50341364e02d0e69ebb21c8c0d063e729ddc7db0a8d0543e7a0188781b6e')
- # license
- install -D -m 644 \
- "${srcdir}"/usr/share/doc/"${_pkgname}"/copyright \
- "${pkgdir}"/usr/share/licenses/"${_pkgname}"/LICENSE
- # manpage
- install -D -m 644 \
- "${srcdir}"/usr/share/man/man1/"${_pkgname}".1.gz \
- "${pkgdir}"/usr/share/man/man1/"${_pkgname}".1.gz
+package() {
+ install -D -m0755 "$_pkgname-v$pkgver/$_pkgname" "${pkgdir}/usr/bin/$_pkgname"
}