summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Kitching2018-05-28 17:13:03 +0100
committerChris Kitching2018-05-28 17:13:03 +0100
commitadf63bb646bcc43d8548f9e60e575fa70a97776f (patch)
tree3f3aeae59cbe7069aaca4ec6c5f97992b1cb8503 /PKGBUILD
parent294971da45eaf0011b7dfdc666cd429f599fd04d (diff)
downloadaur-adf63bb646bcc43d8548f9e60e575fa70a97776f.tar.gz
Avoid fetching the git repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49aa03354038..d5eb278d473d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
pkgname=shellcheck-git-static
-pkgver=0.4.6
+pkgver=0.4.7
pkgrel=1
pkgdesc="shellcheck-static, but using the latest-commit builds maintained by the author"
license=("AGPL3")
arch=("i686" "x86_64")
depends=('gmp')
conflicts=("shellcheck")
-provides=("shellcheck=0.4.6")
+provides=("shellcheck=${pkgver}")
source=(
"https://storage.googleapis.com/shellcheck/shellcheck-latest.linux.x86_64.tar.xz"
-
- # We need this just to compute the pkgver to use :D
- "git+https://github.com/koalaman/shellcheck.git#branch=master"
)
-sha256sums=('SKIP' 'SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/shellcheck"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/shellcheck-latest"
+ ./shellcheck -V | sed -nE 's/^version: (.*)$/\1/p'
}
package() {