summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Kitching2019-08-04 01:33:56 +0100
committerChris Kitching2019-08-04 01:33:56 +0100
commit8ed578047307015f5691a498e61b0817a13fb77f (patch)
treeddafdaeb39480eac2c10152f0294214c644c571b /PKGBUILD
parentba4b6cb56b8a72ee38a4ced5559cfa1657106e1f (diff)
downloadaur-shellcheck-static.tar.gz
Use upstream sha512sum, and named packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce490613388e..f5d18d46d6cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
pkgname=shellcheck-static
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
+url="https://shellcheck.net"
pkgdesc="shellcheck, without the 130MB haskell dependencies"
license=("AGPL3")
arch=("x86_64")
@@ -10,11 +11,12 @@ provides=("shellcheck=$pkgver")
# The statically-linked binary provided by the developer. See:
# https://github.com/koalaman/shellcheck#installing
-source=("https://storage.googleapis.com/shellcheck/shellcheck-stable.linux.x86_64.tar.xz")
-sha256sums=('092f8ece0bb8413c835f4ecc14c9f1157ebb44a36a216e3d617d1048ecdfce1b')
+source=("https://storage.googleapis.com/shellcheck/shellcheck-v${pkgver}.linux.${CARCH}.tar.xz")
+# From https://storage.googleapis.com/shellcheck/shellcheck-v${pkgver}.linux.${CARCH}.tar.xz.sha512sum
+sha512sums=('84e06bee3c8b8c25f46906350fb32708f4b661636c04e55bd19cdd1071265112d84906055372149678d37f09a1667019488c62a0561b81fe6a6b45ad4fae4ac0')
package() {
- cd "${srcdir}/shellcheck-stable"
+ cd "${srcdir}/shellcheck-v$pkgver"
install -Dt "${pkgdir}/usr/bin" "shellcheck"
install -Dt "${pkgdir}/usr/share/shellcheck" "LICENSE.txt" "README.txt"
}