summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Feletto2020-12-30 11:51:53 +0100
committerAndrea Feletto2020-12-30 11:51:53 +0100
commit8f48f13043aad4707c3fa3ed476d676b606cccad (patch)
treefd69f95f6e75f6af88f628e6506331e08cfaebb5 /PKGBUILD
downloadaur-shellect-git.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dab95526bbc7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=shellect-git
+_pkgname=${pkgname%-*}
+pkgver=r19.c920ab5
+pkgrel=1
+pkgdesc='Selection system written in POSIX shell.'
+arch=('any')
+url='https://github.com/huijunchen9260/shellect'
+license=('GPL3')
+provides=('shellect')
+conflicts=('shellect')
+source=("git+https://github.com/huijunchen9260/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 'shellect' -t "$pkgdir/usr/bin"
+ install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 'README.md' -t "$pkgdir/usr/share/doc/$_pkgname"
+}
+