summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-08-14 12:23:28 +1200
committercaltlgin2020-08-14 12:23:28 +1200
commit4ff48b858b17be66a754033cff88ddcaa0972909 (patch)
treecda51d60c6ce2c9aecb9e18d34617ece43d4bc59 /PKGBUILD
parent9636fffcbdbbb469d8764e748d4668dbf0c505e4 (diff)
downloadaur-4ff48b858b17be66a754033cff88ddcaa0972909.tar.gz
Adopt and Update PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 32 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cf768610a1e..96c9ab3912c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,44 @@
-# Maintainer: peeweep <peeweep at 0x0 dot ee>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: peeweep <peeweep at 0x0 dot ee>
-pkgname=sherlock-git
-pkgver=0.10.6.r1003.45a8c5e
+_pkgname=sherlock
+pkgname=${_pkgname}-git
+pkgver=r1276.ca89d12
pkgrel=1
-pkgdesc="Find usernames across social networks"
+pkgdesc='Hunt down social media accounts by username across social networks'
arch=('any')
-url="https://github.com/sherlock-project/sherlock"
+url='https://github.com/sherlock-project/sherlock'
license=('MIT')
-depends=(
- 'python-beautifulsoup4'
- 'python-certifi'
- 'python-colorama'
- 'python-lxml'
- 'python-pysocks'
- 'python-requests'
- 'python-requests-futures'
- 'python-soupsieve'
- 'python-stem'
- 'python-torrequest'
-)
-makedepends=('git')
-source=(
- "${pkgname}::git+${url}.git"
- "sherlock.sh"
-)
+depends=('python'
+ 'python-beautifulsoup4'
+ 'python-certifi'
+ 'python-colorama'
+ 'python-lxml'
+ 'python-pysocks'
+ 'python-requests'
+ 'python-requests-futures'
+ 'python-soupsieve'
+ 'python-stem'
+ 'python-torrequest')
+makedepends=('git' 'python-setuptools')
+provides=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git"
+ "${_pkgname}.sh")
sha256sums=('SKIP'
- '45bb5034d63681f3e0f0d12f868465024a473b12b2751b00e968fcb7a935497c')
+ '21c364a2de4c5a491d85c1e6e9ecb4913505a436aa0db75fe98b367209913500')
pkgver() {
- cd "${srcdir}/${pkgname}"
- printf "%s.r%s.%s" "$(grep '__version__ = ' sherlock.py | cut -d '"' -f 2)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- install -Dm755 "${srcdir}/sherlock.sh" "${pkgdir}/usr/bin/sherlock"
- install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/sherlock/LICENSE"
- cp -r "${srcdir}/${pkgname}" "${pkgdir}/usr/share/sherlock"
+ install -Dm755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
+ cd "${_pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" {removed_sites.md,sites.md,README.md}
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+ install -dm755 "${pkgdir}/usr/share/${_pkgname}"
+ cp -a "${_pkgname}/"* "${pkgdir}/usr/share/${_pkgname}"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: