summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrea Gómez2021-04-05 20:45:50 -0500
committerAndrea Gómez2021-04-05 20:45:50 -0500
commit1e1bad2fb5374a525a7ed4ce8a896a83697a2bdb (patch)
tree83b4fc8399569038541b2eb214d3bcb2eade707f /PKGBUILD
downloadaur-shhgit-git.tar.gz
Add shhgit-git.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10d98bb5bc9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Andrea Denisse Gómez-Martínez <aur at denisse dot dev>
+
+pkgname=shhgit-git
+_pkgname=${pkgname%-git}
+pkgdesc='Reconnaissance tool for GitLab and GitHub organizations'
+arch=(x86_64 i686 armv7h)
+url='https://github.com/eth0izzle/shhgit'
+_branch='master'
+pkgver=r65.65351a7
+pkgrel=1
+license=('MIT')
+makedepends=(git go)
+source=("$_pkgname::git+$url.git#branch=$_branch")
+sha256sums=('SKIP')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ mkdir -p "${pkgname}/build"
+}
+
+build() {
+ cd $_pkgname
+
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ go build -o build/ .
+}
+
+check() {
+ cd "$_pkgname"
+ go test ./...
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 build/$_pkgname "$pkgdir"/usr/bin/$_pkgname
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}