summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Barri2020-07-29 16:09:43 +1000
committerDavid Barri2020-07-29 16:09:43 +1000
commit79825d70b6129c4fa7bca22f297d23b057fac35a (patch)
tree60a171f08f80726b887b2f4daad5707ca25f71ed /PKGBUILD
downloadaur-79825d70b6129c4fa7bca22f297d23b057fac35a.tar.gz
Shift 5.0.77
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2492195b2b12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: David Barri <japgolly@gmail.com>
+pkgname=shift
+pkgver=5.0.77
+pkgrel=1
+pkgdesc="Shift is the desktop app for streamlining your accounts, apps, and workflows."
+arch=('x86_64')
+url="https://tryshift.com/"
+license=('custom')
+source=("shift-linux-v$pkgver-stable.zip::https://update.tryshift.com/download/version/$pkgver-stable/linux_32")
+sha256sums=('3d6dce832d6dd6f45dfe8fb7a60782035094d71973c2cd336112e735ff87ed9e')
+
+package() {
+ set -e
+ cd Shift-linux-x64
+
+ mkdir -p "$pkgdir/opt"
+ cp -r . "$pkgdir/opt/shift"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ mkdir -p "$pkgdir/usr/bin"
+ cd "$pkgdir/usr/bin"
+ ln -s ../../opt/shift/Shift
+}