summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Witschel2021-02-25 19:04:09 +0100
committerJonas Witschel2021-02-25 19:04:09 +0100
commitd16cfc421060855b8e6693ba5e483d66166599b3 (patch)
tree42ce567076bca5d8b65a110390ea47986012fd6f /PKGBUILD
parentff9cbad749128998fe7ec52f5aef64fd616a8429 (diff)
downloadaur-d16cfc421060855b8e6693ba5e483d66166599b3.tar.gz
upgpkg: shim-efi-git 15.r190.9c48fc3e-1: update to build from main branch
- shim can be built using the vanilla gnu-efi package again, the custom gnu-efi-libs-fedora-git is no longer required. - dos2unix is currently not required in makedepends, this might change once you try to include SBAT data. - The edk2 git submodule is no longer required. - Make compiler warnings non-fatal as in the shim package in [community]. - EFI_PATH is no longer required to find the correct location of the gnu-efi libraries. - ENABLE_HTTPBOOT has been removed in upstream commit 9b0c281db4ca94ef4299911bd966eac8f75877f2, it is now enabled by default.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e780f00f3ce9..b31a11a5a7dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,17 @@
# Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
# Contributor: Pablo Lezaeta <(prflr 88) (arro'a) (gmail) (puntocom)>
pkgname=shim-efi-git
-pkgver=15.r112.dada069
+pkgver=15.r190.9c48fc3e
pkgrel=1
pkgdesc='UEFI shim loader'
arch=('x86_64')
url='https://github.com/rhboot/shim'
license=('BSD')
-makedepends=('git' 'dos2unix' 'gnu-efi-libs-fedora-git')
+makedepends=('git' 'gnu-efi')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+$url.git"
- 'git+https://github.com/rhboot/edk2.git')
-sha512sums=('SKIP'
- 'SKIP')
+source=("git+$url.git#branch=main")
+sha512sums=('SKIP')
pkgver() {
cd shim
@@ -23,14 +21,12 @@ pkgver() {
prepare() {
cd shim
- git submodule init
- git config submodule.edk2.url "$srcdir/edk2"
- git submodule update
+ sed -e 's/-Werror //g' -i Makefile Make.defaults
}
build() {
cd shim
- make EFI_PATH=/usr/lib ENABLE_HTTPBOOT=1
+ make
}
package() {