summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Martin2016-10-19 20:31:13 -0500
committerStephen Martin2016-10-19 20:31:13 -0500
commitdf5105ea47e4d7c78ea3806d3adbb51f6504088a (patch)
treee651dc434ac8dd46f78a19d30f0727ee4b085a83 /PKGBUILD
parent4feabdd87cebb219c66dc17025ea386de0d24e32 (diff)
downloadaur-df5105ea47e4d7c78ea3806d3adbb51f6504088a.tar.gz
Fixed nodejs compile issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 057ece77c7d4..ec8df3a5caf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ license=('AGPL')
depends=('r')
makedepends=('git' 'python2' 'cmake' 'r')
install='accounts.install'
-backup=('shiny-server.conf')
+backup=('etc/shiny-server.conf')
source=('shiny-server::git+https://github.com/rstudio/shiny-server.git'
'shiny-server.service')
pkver(){
@@ -42,7 +42,7 @@ build() {
make
mkdir ../build
- (cd .. && bin/npm --python="$PYTHON" rebuild)
+ (cd .. && bin/npm --python="$PYTHON" install)
(cd .. && ext/node/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js --python="$PYTHON" rebuild)
}