summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNikola Hadžić2022-06-21 23:21:31 +0200
committerNikola Hadžić2022-06-21 23:21:31 +0200
commit0d7bbdbf890f9b04321eab8edd9be4aa94de522d (patch)
treec179dd50af63ed04be528287c4612ce7663e26d4 /PKGBUILD
downloadaur-0d7bbdbf890f9b04321eab8edd9be4aa94de522d.tar.gz
1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f64a6747f14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nikola Hadžić <nikola.hadzic.000@protonmail.com>
+pkgname="shnote"
+pkgver="1.0"
+pkgrel=1
+pkgdesc="A simple TUI note-taking application written in Bash"
+arch=("any")
+url="https://gitlab.com/NH000/shnote"
+license=("GPL3")
+depends=("bash" "coreutils" "gettext")
+makedepends=("sed")
+source=("$pkgname-$pkgver::git+$url#tag=6913c40c9122c0ce2e7ee45cdd33696afea1c519")
+sha256sums=("SKIP")
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -D "shnote.sh" "$pkgdir/usr/bin/shnote"
+ sed -i '20s/$/"\/usr\/share\/locale"/' "$pkgdir/usr/bin/shnote"
+ sed -i '21s/$/"shnote"/' "$pkgdir/usr/bin/shnote"
+
+ mkdir -p "$pkgdir/usr/share/locale/sr/LC_MESSAGES"
+ msgfmt -o "$pkgdir/usr/share/locale/sr/LC_MESSAGES/shnote.mo" "po/sr.po"
+ mkdir -p "$pkgdir/usr/share/locale/sr_RS@latin/LC_MESSAGES"
+ msgfmt -o "$pkgdir/usr/share/locale/sr_RS@latin/LC_MESSAGES/shnote.mo" "po/sr_RS@latin.po"
+}