summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoost Bremmer2022-10-31 15:23:37 +0100
committerJoost Bremmer2022-10-31 15:23:37 +0100
commit1f649135821da8c17e1ccfab469df04b9b637313 (patch)
treec9183b0dae22c082a6e2b8eb97a2affca834ab0b /PKGBUILD
parentc1e0850853c8042ef0b369cf2b345d6aae39e3a8 (diff)
downloadaur-1f649135821da8c17e1ccfab469df04b9b637313.tar.gz
Update shortcut-pages package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 5 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e39d135a5bd1..d5282c253629 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,25 @@
pkgbase=shortcut-git
pkgname=('shortcut-pages-git' 'shortcut-pages-extra-git' 'shortcut-c-client-git')
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A commandline client to list shortcuts"
url="https://github.com/mt-empty/shortcut-c-client"
arch=('x86_64')
license=('unknown')
makedepends=('git')
source=("shortcut-pages::git+https://github.com/mt-empty/shortcut-pages.git"
- "shortcut-c-client::git+https://github.com/mt-empty/shortcut-c-client.git"
- "shortcut-c-client.patch")
+ "shortcut-c-client::git+https://github.com/mt-empty/shortcut-c-client.git")
sha256sums=('SKIP'
- 'SKIP'
- 'f9b9c032afda9f3312bc4cc3edd6890bc7ad0d76174aaaeac1af03a0f134bfc2')
+ 'SKIP')
pkgver() {
cd "${srcdir}/shortcut-pages"
printf "0.2.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/shortcut-c-client"
- # patch -Np1 --input "${srcdir}/shortcut-c-client.patch"
-
-}
-
build() {
cd "${srcdir}/shortcut-c-client"
- make shortcut
+ make DEST_DIR="/usr/share" shortcut
}
@@ -55,7 +47,7 @@ package_shortcut-pages-extra-git() {
license=('unknown')
provides=('shortcut-pages-extra' 'shortcut-pages')
- cd "$srcdir/shortcut-pages/nonGUI"
+ cd "$srcdir/shortcut-pages/misc/nonGUI"
install -dvm755 "${pkgdir}/usr/share/shortcut/pages"
find . -type f -iname "*.md" -not -regex "\.\/\(c\|git\|r\|unity\|\)\.md$" -exec \