summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-05-27 16:58:20 -0600
committerMark Wagie2023-05-27 16:58:20 -0600
commit00c56c1a8de68b496b42f65b5cbb30d7c4aadaba (patch)
tree6b7abb5ac91b1d6642f4e007ad9db9e95d91089d /PKGBUILD
parent002437f62540f785b8c3321f489b96167eb0508f (diff)
downloadaur-00c56c1a8de68b496b42f65b5cbb30d7c4aadaba.tar.gz
use local cargo cache
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78e83d7e7fcb..db56951b0d82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=shortwave-git
-pkgver=3.2.0.r0.g6fb4acd
+pkgver=3.2.0.r25.gd22eaa8
pkgrel=1
pkgdesc="Find and listen to internet radio stations"
arch=('x86_64' 'aarch64')
@@ -23,11 +23,13 @@ pkgver() {
prepare() {
cd "$srcdir/Shortwave"
+ export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
cargo fetch --target "$CARCH-unknown-linux-gnu"
}
build() {
+ export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
arch-meson Shortwave build
meson compile -C build