summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-10-15 11:15:55 -0600
committerMark Wagie2022-10-15 11:15:55 -0600
commit05ec7738d07d4cbbd787c1839c547c2cb4cc66e3 (patch)
treeb3907e8e85e967bb2dbcdf31b7e7f694f9ebc4e3 /PKGBUILD
parentd80ff75294f62fa129379cca05e882b1bcbe01e8 (diff)
downloadaur-05ec7738d07d4cbbd787c1839c547c2cb4cc66e3.tar.gz
PKGBUILD improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a15f95cd944a..f0e56923ef8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=shortwave-git
-pkgver=3.0.0.r44.g40ae221
+pkgver=3.1.0.r0.gde062d5
pkgrel=1
pkgdesc="Find and listen to internet radio stations"
arch=('x86_64' 'aarch64')
@@ -21,15 +21,9 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/Shortwave"
- export RUSTUP_TOOLCHAIN=stable
- cargo fetch --target "$CARCH-unknown-linux-gnu"
-}
-
build() {
export RUSTUP_TOOLCHAIN=stable
- arch-meson Shortwave build -Dprofile=development
+ arch-meson Shortwave build
meson compile -C build
}