summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-08-11 14:19:27 -0600
committerMark Wagie2021-08-11 14:19:27 -0600
commit6a8d7b24f454f115ecb0b28dba79189d292a8b54 (patch)
treecf7f88bd69f2b59828255ca07a9b066244014017 /PKGBUILD
parent95f153e8683e53430d014e21320059741ec2a605 (diff)
downloadaur-6a8d7b24f454f115ecb0b28dba79189d292a8b54.tar.gz
PKGBUILD improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b9b7aea22e3..6ea59ef8ec18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=shortwave-git
-pkgver=2.0.1.r46.g28c41ef
-pkgrel=2
+pkgver=2.0.1.r51.ga6841fa
+pkgrel=1
pkgdesc="Find and listen to internet radio stations"
arch=('x86_64' 'aarch64')
url="https://gitlab.gnome.org/World/Shortwave"
license=('GPL3')
depends=('gst-plugins-bad' 'gtk4' 'libadwaita')
-makedepends=('git' 'meson' 'rust' 'wayland-protocols')
+makedepends=('cargo' 'git' 'meson' 'wayland-protocols')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}::git+https://gitlab.gnome.org/World/Shortwave.git")
@@ -19,7 +19,13 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
build() {
+ export RUSTUP_TOOLCHAIN=stable
arch-meson "${pkgname%-git}" build -Dprofile=development
meson compile -C build
}