summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-08-06 15:05:18 -0600
committerMark Wagie2021-08-06 15:05:18 -0600
commit95f153e8683e53430d014e21320059741ec2a605 (patch)
tree9a8d419f6a309ebb875392f24ae66054a69055cc /PKGBUILD
parent28dd75405982e434ebbdb6d469daa30613c7bfd4 (diff)
downloadaur-95f153e8683e53430d014e21320059741ec2a605.tar.gz
use development profile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18933c32dcff..1b9b7aea22e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=shortwave-git
-pkgver=1.1.1.r282.g7ec5b7d
+pkgver=2.0.1.r46.g28c41ef
pkgrel=2
pkgdesc="Find and listen to internet radio stations"
arch=('x86_64' 'aarch64')
@@ -15,19 +15,19 @@ source=("${pkgname%-git}::git+https://gitlab.gnome.org/World/Shortwave.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- arch-meson "${pkgname%-git}" build
- meson compile -C build
+ arch-meson "${pkgname%-git}" build -Dprofile=development
+ meson compile -C build
}
check() {
- meson test -C build --print-errorlogs
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
}