summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2019-11-13 20:34:34 +0100
committerPhilip Goto2019-11-13 20:34:34 +0100
commitf18993ada3a853f9b9411a916891d59351489c8a (patch)
tree07b9f94492907f237092da8cb1a8f0e7ca285851 /PKGBUILD
parent996487a773cd4a0c1feac1f7ccec8a1ad1bc02dc (diff)
downloadaur-f18993ada3a853f9b9411a916891d59351489c8a.tar.gz
Update versioning and makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72002d6ff2a1..9f621dd2dc3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=shortwave-git
-pkgver=r244.ee8b98a
+pkgver=0.0.1.r0.gcd80fc2
pkgrel=1
pkgdesc="Find and listen to internet radio stations"
arch=(i686 x86_64 armv6h armv7h)
@@ -9,7 +9,7 @@ url="https://gitlab.gnome.org/World/Shortwave"
license=(GPL3)
depends=(gstreamer
libhandy)
-makedepends=(cargo
+makedepends=(appstream-glib
git
gobject-introspection
gst-plugins-base-libs
@@ -17,17 +17,14 @@ makedepends=(cargo
libhandy
meson
rust)
-provides=(shortwave)
-conflicts=(shortwave)
+provides=(shortwave gradio)
+conflicts=(shortwave gradio)
source=("git+https://gitlab.gnome.org/World/Shortwave.git")
sha256sums=('SKIP')
pkgver() {
- cd Shortwave
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd Shortwave
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {