summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2022-04-10 23:05:29 +0200
committerFabioLolix2022-04-10 23:05:29 +0200
commitcc00fe4ebc5e4a579e098e3b0da034e6e85301d8 (patch)
treebafa74f54d2c21fdef4b3f5bea33b03c48c44935 /PKGBUILD
parente2f998709f68189d1997dc639ac427bb97928860 (diff)
downloadaur-cc00fe4ebc5e4a579e098e3b0da034e6e85301d8.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 18 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dae9cb522c43..f5f50d44314b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,32 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: gaelic
+
pkgname=shotwell-git
-_pkgname=shotwell
-pkgver=0.31.4094
-_pkgver=0.31
+pkgver=0.31.3.r143.g5e21249f
pkgrel=1
pkgdesc="A digital photo organizer designed for the GNOME desktop environment"
-arch=('x86_64')
-url="http://yorba.org/shotwell/"
-license=('LGPL2.1')
-depends=('libgee' 'webkit2gtk' 'libgexiv2-git' 'libraw' 'rest'
- 'desktop-file-utils' 'dconf' 'hicolor-icon-theme' 'json-glib'
- 'gst-plugins-base' 'libgphoto2' 'libgudev'
- 'gcr' 'libgdata' 'opencv')
-makedepends=('intltool' 'vala>=0.17.2' 'gnome-doc-utils' 'itstool')
+arch=(x86_64)
+url="https://wiki.gnome.org/Apps/Shotwell"
+license=(LGPL2.1)
+depends=(libgee libgexiv2 libraw libgdata libgphoto2)
+makedepends=(git vala meson ninja itstool)
+provides=(shotwell)
conflicts=(shotwell)
-source=("$_pkgname"::'git+https://gitlab.gnome.org/GNOME/shotwell.git')
+source=("git+https://gitlab.gnome.org/GNOME/shotwell.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
- echo $_pkgver.$(git rev-list --count HEAD)
-}
-
-prepare() {
- cd "$srcdir/$_pkgname"
- sed -e 's/org.gnome.Shotwell/shotwell/g' -i data/org.gnome.Shotwell.desktop.in
- sed -e 's/org.gnome.Shotwell/shotwell/g' -i data/org.gnome.Shotwell-Viewer.desktop.in
- meson build -Dface-detection=true --prefix=/usr
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long --tags | sed 's/^shotwell-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname/build"
- ninja
+ cd "${srcdir}/${pkgname%-git}"
+ arch-meson -D unity_support=false build
+ ninja -C build
}
package() {
- cd "$_pkgname/build"
- DESTDIR="$pkgdir" ninja install
+ cd "${srcdir}/${pkgname%-git}"
+ DESTDIR="${pkgdir}" meson install -C build
}