summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2017-10-21 18:33:09 +0200
committerJaroslav Lichtblau2017-10-21 18:33:09 +0200
commit4b2806d452f81e0ca4a82688095d82d1bfc23749 (patch)
treec8c7bed74357c25378b162deb83b87f87be62885 /PKGBUILD
downloadaur-4b2806d452f81e0ca4a82688095d82d1bfc23749.tar.gz
shp2svg dropped from [community]
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..052f57372766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer:
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+
+pkgname=shp2svg
+pkgver=0.5.1
+pkgrel=5
+pkgdesc="Takes the text input from shp2pgsql and converts it to SVG files"
+arch=('any')
+url="http://old.carto.net/papers/svg/utils/shp2svg/"
+license=('LGPL')
+depends=('postgis' 'perl-math-round')
+source=(http://old.carto.net/papers/svg/utils/shp2svg/ogis2svg.pl)
+sha256sums=('05f8ff0eac46f54084793717c4542e37bc0acb55fdd822fe75db8aa59bc90bfd')
+
+package() {
+ install -Dm755 "${srcdir}"/ogis2svg.pl "${pkgdir}"/usr/bin/ogis2svg.pl
+ # add a symlink because the name of the script is a little confusing.
+ ln -sf /usr/bin/ogis2svg.pl "${pkgdir}"/usr/bin/shp2svg
+}