summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Whatson2019-11-08 14:42:17 +1000
committerAndrew Whatson2019-11-08 14:50:46 +1000
commita8debe3f26a1bf20670fd93a5ffb080d89d6e75c (patch)
tree6d5724fe7887c978f35af647d7b7a0f2bd23a98c /PKGBUILD
downloadaur-a8debe3f26a1bf20670fd93a5ffb080d89d6e75c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb513d53e6cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Andrew Whatson <whatson@gmail.com>
+pkgname=shroud
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='A simple command-line secret manager using GNU Guile'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('guile' 'gnupg' 'xclip')
+url="https://dthompson.us/projects/shroud.html"
+source=("https://files.dthompson.us/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "fix-version-detect.patch")
+sha256sums=('9912fc92ae588e1bdb7999daa893aa4b7c3673ea1e0f895799797de11ff483f8'
+ '427dc6f5cc4185c2138ba454d7a822d3f99853e0881cfb3361a9ac8588fe9b18')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -p1 -i ../fix-version-detect.patch
+}
+
+build() {
+ cd ${pkgname}-${pkgver}
+ GUILE=/usr/bin/guile ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}