summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcel O'Neil2017-05-22 19:50:17 -0400
committerMarcel O'Neil2017-05-22 19:50:17 -0400
commit16c4f4d2aa92df3946434aedc3d35027e52e9560 (patch)
tree35868ea5ec9a8ed2a797240e18833341c4e9d3fd /PKGBUILD
downloadaur-16c4f4d2aa92df3946434aedc3d35027e52e9560.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb5b5ebb1bbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Marcel O'Neil <marcel@marceloneil.com>
+
+pkgname=sia-daemon
+pkgver=v1.2.2
+pkgrel=1
+pkgdesc="Blockchain-based marketplace for file storage"
+arch=('x86_64')
+url="https://sia.tech"
+license=('MIT')
+depends=('glibc')
+source=("https://github.com/NebulousLabs/Sia/releases/download/${pkgver}/Sia-${pkgver}-linux-amd64.zip")
+sha256sums=('b11e4535510b3affe0820059226507d68463ddc8cf2c5f59fbe2ff9f8931055c')
+
+package() {
+ cd $srcdir/Sia-$pkgver-linux-amd64
+
+ install -Dm755 siac "${pkgdir}/usr/bin/siac"
+ install -Dm755 siad "${pkgdir}/usr/bin/siad"
+}