summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122021-07-13 20:27:59 +0200
committerwillemw122021-07-13 20:27:59 +0200
commit6732051c24d4c622218f9006cb6a0605bc2a804e (patch)
treeb29164604cbd8278672713f8384b3b96f1e3b248 /PKGBUILD
parent9c2838284f9d9345cdd42251faf447a16c05bfa9 (diff)
downloadaur-6732051c24d4c622218f9006cb6a0605bc2a804e.tar.gz
Update pip install
Fix some shellcheck warnings. Minor edits.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2829fedd493..90783b0ed058 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# That is the only reason why this package ends on -git.
pkgname=sickchill-git
-pkgver=2021.6.16.r0
+pkgver=2021.7.12.6.r0
pkgrel=1
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
@@ -21,12 +21,13 @@ install=$pkgname.install
source=('sickchill.service'
'sickchill.sysusers'
'sickchill.tmpfile')
-md5sums=('309b8555af7b355f16a3ec784771f426'
- '97fb191af2e326d5aba2cf58270b4feb'
- '515f13e391105a716ef6763ba8533fc7')
+sha256sums=('ca6a73f7c2019ddda2b338eb63be560bf1a5d6ae5ceab969dc032c05b6d2d7b5'
+ '1467f3613f5f25e678e373465dc09a28230f7cdf07af23875a0896a509c3b850'
+ '43f7916915942661dad4966b989aed0a2ca85b19bceb31689cf64f83842ef521')
pkgver() {
- local version="$(curl -s "https://pypi.org/pypi/${pkgname%-git}/json" | jq --raw-output --join-output '.info.version')"
+ local version
+ version="$(curl -s "https://pypi.org/pypi/${pkgname%-git}/json" | jq --raw-output --join-output '.info.version')"
printf "%s.r0" "$version" | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
@@ -34,13 +35,16 @@ build() {
#python -m venv build
export XDG_CACHE_HOME=cache/pip
VIRTUALENV_OVERRIDE_APP_DATA=cache/virtualenv virtualenv build
- build/bin/pip install --isolated --no-warn-script-location --prefix=. --root=build --cache-dir=cache --default-timeout=60 --progress-bar=off sickchill
+ PIP_CONFIG_FILE=/dev/null build/bin/pip install \
+ --ignore-installed --isolated --cache-dir=cache --prefix=. --root=build \
+ --default-timeout=60 --disable-pip-version-check --no-warn-script-location --progress-bar=off \
+ sickchill
sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' build/bin/SickChill.py
}
package() {
- install -Dm644 sickchill.service "$pkgdir/usr/lib/systemd/system/sickchill.service"
+ install -Dm644 sickchill.service -t "$pkgdir/usr/lib/systemd/system"
install -Dm644 sickchill.sysusers "$pkgdir/usr/lib/sysusers.d/sickchill.conf"
install -Dm644 sickchill.tmpfile "$pkgdir/usr/lib/tmpfiles.d/sickchill.conf"