summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOndrej Patrovic2016-06-22 08:02:46 -0400
committerOndrej Patrovic2016-06-22 08:02:46 -0400
commit522f797b4b651f1e0c988f0198087d4481e92c04 (patch)
treeaa9fe28cacd694c76a0f296adb206a3a252f7e55 /PKGBUILD
parenta78f7694e757906ff964988a3c05103886c73e03 (diff)
downloadaur-522f797b4b651f1e0c988f0198087d4481e92c04.tar.gz
* Fixed tab spacing issues
* Updated checksum for sickgear.service * Fixed problem with .git directory not being copied
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 29 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ec022c735cf..e488fa12f84d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,30 +3,38 @@
_pkgname=sickgear
pkgname=${_pkgname}-git
pkgver=0.11.12.r0.g9198eb6
-pkgrel=1
+pkgrel=2
pkgdesc="Provides management of TV shows and/or Anime, detects new episodes, links to downloader apps, and more."
arch=('any')
url="https://github.com/SickGear/SickGear"
license=('GPL3')
makedepends=('git')
depends=('python2-cheetah')
-optdepends=('python2-notify: desktop notifications'
+optdepends=('sabnzbd: supported NZB downloader'
+ 'transmission-cli: supported torrent client'
+ 'deluge: supported torrent client'
+ 'rtorrent: supported torrent client'
+ 'qbittorrent: supported torrent client'
+ 'python2-notify: desktop notifications'
'python2-pyopenssl: enable SSL'
- 'unrar: RAR archives')
+ 'unrar: RAR extraction support'
+ 'git: pull new versions from git')
provides=(${_pkgname})
-conflicts=(${_pkgname})
+conflicts=(${_pkgname}
+ 'sickbeard'
+ 'sickrage'
+ 'sickrage-git'
+ 'sickrage2-git')
options=('!strip')
install=${_pkgname}.install
-source=(
- "sickgear.service"
- "sickgear.tmpfiles"
- "sickgear.sysusers"
- "fix-signal-handling.patch"
- "${_pkgname}::git+https://github.com/SickGear/SickGear.git"
-)
+source=('sickgear.service'
+ 'sickgear.tmpfiles'
+ 'sickgear.sysusers'
+ 'fix-signal-handling.patch'
+ "${_pkgname}::git+https://github.com/SickGear/SickGear.git")
-sha256sums=('1b80f3f749e357e1509dd4524eecb3f044ec0a266cf96c31f665dabb7fe07f8f'
+sha256sums=('76108d56417bc6e5352db779c7e74812eda07b440cc293547809aa9504e10209'
'5c7a327168f2b2d361eeaa9e9f82e79a87381908d8ba6b1d1eb90ac64ad38ac2'
'54873ee12aa334a0c0830dbe48251f994d8ae851ae0b55250c098ff9f7f9ea60'
'fae4616bf9dbf19d5bb2fcc89abd49b27db9f1f0181589a60bbcde07b840ae99'
@@ -38,16 +46,18 @@ pkgver() {
}
prepare() {
- cd "${_pkname}"
- patch -Np1 -i "${srcdir}/fix-signal-handling.patch"
+ cd "${_pkname}"
+
+ # Patch to fix SIGINT and SIGTERM signal handling
+ patch -Np1 -i "${srcdir}/fix-signal-handling.patch"
}
package() {
- install -dm 755 "${pkgdir}"/{opt/sickgear/app,usr/lib/{tmpfiles.d,sysusers.d,systemd/system}}
+ install -dm 755 "${pkgdir}"/{opt/sickgear/app,usr/lib/{tmpfiles.d,sysusers.d,systemd/system}}
- cp -dr --no-preserve=ownership "${_pkgname}"/* "${pkgdir}/opt/sickgear/app/"
+ cp -dRT --no-preserve=ownership "${_pkgname}/" "${pkgdir}/opt/sickgear/app/"
- install -m 644 sickgear.service "${pkgdir}/usr/lib/systemd/system/"
- install -m 644 sickgear.tmpfiles "${pkgdir}/usr/lib/tmpfiles.d/sickgear.conf"
- install -m 644 sickgear.sysusers "${pkgdir}/usr/lib/sysusers.d/sickgear.conf"
+ install -m 644 sickgear.service "${pkgdir}/usr/lib/systemd/system/"
+ install -m 644 sickgear.tmpfiles "${pkgdir}/usr/lib/tmpfiles.d/sickgear.conf"
+ install -m 644 sickgear.sysusers "${pkgdir}/usr/lib/sysusers.d/sickgear.conf"
}