summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbelinux2018-10-10 11:53:19 +0200
committerbelinux2018-10-10 11:53:19 +0200
commit1f5c38f07b4ed32e69a23cb58edf6b11df46dc15 (patch)
treec8697e07185cf5fe446ddd5ab800ccbcaa2b17f8 /PKGBUILD
parent082fbcdcdb38095df555749e3c7faddcf12d3c3f (diff)
downloadaur-1f5c38f07b4ed32e69a23cb58edf6b11df46dc15.tar.gz
updated to Sick-Rage repo, version v2018.10.10-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 35 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbb46451af76..02a8afe5b059 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,45 @@
-# Maintainer: gls < ghostlovescorebg at gmail dot com>
+# Maintainer: Carlos Bellino <carlosbellino@gmail.com>
pkgname=sickrage
-pkgver=4.2.5
-pkgrel=3
-pkgdesc="A PVR application that downloads and manages your TV shows. Echel0n fork of sickbeard, with tvrage, torrents and anime support."
+_gitname=Sick-Rage
+_gitauthor=Sick-Rage
+_sickrage_dir="/opt/sickrage"
+pkgver=2018.10.10
+pkgrel=2
+pkgdesc="Automatic Video Library Manager for TV Shows. It watches for new episodes of your favorite shows, and when they are posted it does its magic."
arch=('any')
-url="https://github.com/SiCKRAGETV/SickRage"
+url="https://github.com/${_gitauthor}/${_gitname}"
license=('GPL3')
-depends=('python2-mako' 'python2-cheetah')
-optdepends=('sabnzbd: NZB downloader'
- 'transmission-cli: supported torrent client'
- 'deluge: supported torrent client'
- 'rtorrent: supported torrent client'
- 'qbittorrent: supported torrent client'
- 'python2-notify: desktop notifications (libnotify)'
- 'unrar: rar extraction support'
- 'git: pull new versions from git')
-provides=('sickbeard-tvrage-git')
-conflicts=('sickbeard' 'sickbeard-piratebay-git' 'sickbeard-tvrage-git' 'sickrage-git')
-replaces=('sickbeard-tvrage-git')
+
+depends=('nodejs'
+ 'python2-babel'
+ 'python2-cheetah'
+ 'python2-mako')
+
+optdepends=('python2-notify'
+ 'unrar')
+
+conflicts=(${_pkgname}
+ 'pymedusa'
+ 'sickbeard'
+ 'sickrage-git'
+ 'sickrage2-git'
+ 'sickgear-git')
+
options=('!strip')
-install='sickrage.install'
-source=("https://github.com/SiCKRAGETV/SickRage/archive/${pkgver}.tar.gz"
- 'sickrage-system.service'
- 'sickrage-user.service'
- 'sickrage.tmpfile')
+install=${pkgname}.install
-md5sums=('3c13a8468d3dfe3e7ffe2412cfe29692'
- '518016cf0c33e384b1e0977294fafa17'
- '9fdba8dda62d8205e2cfc3268f19f32f'
- 'fa9ac7ae0b6c55033ef8fe5b7c83bb0f')
+source=("https://github.com/${_gitauthor}/${_gitname}/archive/v${pkgver}-${pkgrel}.tar.gz"
+ "${pkgname}.service"
+ "${pkgname}.install")
-package() {
- mkdir -p "${pkgdir}/opt/sickrage"
- chmod 775 "${pkgdir}/opt/sickrage"
- cp -r ${srcdir}/SiCKRAGE-${pkgver}/* ${pkgdir}/opt/sickrage
+md5sums=('024e9edce2dd57aa790cc4fa5a813a70'
+ '18e8ac10a90c7eb3cc596caa02261a3e'
+ 'ac4c96c5d3b7b4a86c653929c5f4aa60')
- install -D -m644 sickrage-system.service "${pkgdir}/usr/lib/systemd/system/sickrage.service"
- install -D -m644 sickrage-user.service "${pkgdir}/usr/lib/systemd/user/sickrage.service"
- install -D -m644 sickrage.tmpfile "${pkgdir}/usr/lib/tmpfiles.d/sickrage.conf"
+package() {
+ install -Dm644 "${srcdir}/${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -dm755 "${pkgdir}${_sickrage_dir}"/{app,data}
- find ${pkgdir} -type d -name '.git' -exec rm -r '{}' +
+ cp -rp "${srcdir}/${_gitname}-${pkgver}-${pkgrel}"/* "${pkgdir}${_sickrage_dir}"/app/
}
-
-# vim: set ts=2 sw=2 ft=sh noet: