summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordreieck2023-04-13 22:39:41 +0200
committerdreieck2023-04-13 22:39:41 +0200
commit2dd81cf04b677d04ef1aee534f2347d90bb80f61 (patch)
tree24eb45233179e97d94c37e6d94282fab2417fe15 /PKGBUILD
parent0b012c02cbf2794bc666ead24cceb5e88c06c39d (diff)
downloadaur-2dd81cf04b677d04ef1aee534f2347d90bb80f61.tar.gz
Splitting out widelands support to extra package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ebfec7357e1..b5ad70c160ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: dreieck
+# Maintainer: dreieck (https://aur.archlinux.org/account/dreieck)
pkgbase="siedler2-data"
pkgname=(
"siedler2-data"
"siedler2-doc"
)
-pkgdesc="Game data files and manual of Blue Byte's 'Siedler II'/'Settlers II' to be used with 'Return to the Roots'. Maps can also be played with 'widelands'."
+pkgdesc="Game data files and manual of Blue Byte's 'Siedler II'/'Settlers II' to be used with 'Return to the Roots'."
url='http://archive.org/details/die_siedler_2_151'
arch=('any')
pkgver='venividivici_gold'
-pkgrel=8
+pkgrel=9
license=('unknown: proprietary')
options+=('emptydirs')
@@ -30,25 +30,16 @@ package_siedler2-data() {
pkgdesc="Game data files of Blue Byte's 'Siedler II'/'Settlers II' to be used with 'Return to the Roots'. Maps can also be played with 'widelands'."
optdepends+=(
"return-to-the-roots: To play the game."
- "widelands: To play the maps with widelands."
+ "widelands-maps-siedler2: To play the maps in the game 'widelands' (some things might not work correctly)."
"siedler2-doc: The original Blue Byte manual."
)
- provides=(
- "widelands-maps-settlers2"
- )
+ provides=("settlers2-data=${pkgver}")
cd "${srcdir}"
install -v -m 755 -d "${pkgdir}/usr/share/s25rttr/S2"
cp -av "${srcdir}"/{DATA,GFX} "${pkgdir}/usr/share/s25rttr/S2"/
chmod -R a+Xr "${pkgdir}/usr/share/s25rttr/S2"/*
- install -v -m755 -d "${pkgdir}/usr/share/widelands/maps/Settlers II-maps"
- cd "${pkgdir}/usr/share/widelands/maps/Settlers II-maps"
- ln -sv "/usr/share/s25rttr/S2/DATA/MAPS" "Campaigns"
- ln -sv "/usr/share/s25rttr/S2/DATA/MAPS2" "Continents"
- ln -sv "/usr/share/s25rttr/S2/DATA/MAPS3" "Older maps"
- ln -sv "/usr/share/s25rttr/S2/DATA/MAPS4" "Newer maps"
-
install -v -D -m644 "${srcdir}/license-note.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license-note.txt"
}