summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfeldrise2017-12-31 11:38:24 +0100
committerfeldrise2017-12-31 11:38:24 +0100
commit5cd19f9a7c678b57fd5247867ca753d11cfd3971 (patch)
treec2dc6660e9b81385174e9c2e6f60291a957c82d0 /PKGBUILD
parent0c3d81b7c0a4369765347f908ae8103d055789a3 (diff)
downloadaur-5cd19f9a7c678b57fd5247867ca753d11cfd3971.tar.gz
[Compile] directly Sielo now
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9db787bd1e49..b5bea46c4914 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=sielo-browser
pkgname=sielo-browser
pkgver=1.8.00
-pkgrel=1
+pkgrel=2
pkgdesc="A simple, customizable and fast web browser"
arch=(x86_64)
url="https://feldrise.com/Sielo"
@@ -11,10 +11,13 @@ license=('custom:MIT')
depends=('openssl-1.0' 'qt5-base' 'qt5-webengine' 'qt5-webchannel' 'qt5-location' 'qt5-declarative')
replaces=('sielo-navigateur')
source=(https://www.feldrise.com/Sielo/Linux/$pkgname-$pkgver.tar.gz)
-md5sums=('3f6d5701665b58bfdec650b4cf99834b')
+md5sums=('308803cc8803d49e51eab9f252bf9f8e')
package() {
cd "$srcdir/$pkgname-$pkgver"
- cp -r usr $pkgdir/
+ mkdir build && cd build && cmake .. && make -j2
+ cp -r ../usr $pkgdir/
+ cp sielo-browser $pkgdir/usr/bin
+ cp SNCompiler/sielo-compiler $pkgdir/usr/bin
chmod +x $pkgdir/usr/bin/sielo-browser
chmod +x $pkgdir/usr/bin/sielo-compiler
}