summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorm-pilia2017-10-31 12:05:34 +0100
committerm-pilia2017-10-31 12:05:34 +0100
commite09c83b41982f189b5cd44cb6fbeeea110983c86 (patch)
treea0459b6249fbbcf10c51c4929811901223b4f80a /PKGBUILD
downloadaur-e09c83b41982f189b5cd44cb6fbeeea110983c86.tar.gz
submission
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c304555f03f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
+pkgname=sigar-git
+_pkgname=sigar
+pkgver=sigar.1.6.4.r600.ga6c61edf
+pkgrel=1
+pkgdesc="System Information Gatherer And Reporter"
+arch=('x86_64')
+url="https://github.com/hyperic/sigar"
+license=('apache')
+depends=()
+makedepends=('cmake')
+source=("git+https://github.com/boundary/sigar.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ ./autogen.sh
+ ./configure --prefix="$pkgdir/usr"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make install
+}
+