summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean Lucas2019-10-27 01:48:20 -0400
committerJean Lucas2019-10-27 02:34:34 -0400
commit348f77531a43ec24d5b644be29e389334779b5ca (patch)
tree6c472a407aed1d4b091ecbcc7f4c201255b0d868 /PKGBUILD
parent5849c18edb612d7467955421733f06457e897b06 (diff)
downloadaur-348f77531a43ec24d5b644be29e389334779b5ca.tar.gz
Package merge, miscellaneous cleanup
- Set required minimum Arch Electron version for ABI compatibility with upgraded Electron version in package.json - Add provides/replaces due to package merge - Use a patch file for OpenSSL linking instead of quiet sed patches - Move program files one directory up from lone 'resources' directory - Don't install common license
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0417e1489c26..79e7d253ee6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,28 @@
pkgname=signal-desktop
_pkgname=Signal-Desktop
pkgver=1.27.4
-pkgrel=2
+pkgrel=3
pkgdesc='Electron application that links with Signal on mobile'
arch=(x86_64)
url=https://signal.org
license=(GPL3)
-depends=(electron)
+depends=('electron>=6.1.1')
makedepends=(yarn git python2 'nodejs>=12' npm python)
-conflicts=(signal)
-source=($pkgname-$pkgver.tar.gz::https://github.com/signalapp/Signal-Desktop/archive/v$pkgver.tar.gz
- $pkgname.desktop)
+provides=(signal)
+replaces=(signal)
+source=(
+ $pkgname-$pkgver.tar.gz::https://github.com/signalapp/Signal-Desktop/archive/v$pkgver.tar.gz
+ openssl-linking.patch
+ $pkgname.desktop
+)
sha512sums=('92a934d7680f33803bd7be21f4604719b211036931a6e00565e21a7008d0b35da7dda5c6527458a9498f82a9c9a96a94b868274d1d7e73e09ccb09fe1aea295a'
- 'bcbf8ffc6f6f7e99e59b5ab1517ba231f1d3b2b16a0e27541580f028ebee5027685a8c397212c43008844be352d3b6acf2269e631bc2c6ba05c2eb95f56fef36')
+ 'bcbf8ffc6f6f7e99e59b5ab1517ba231f1d3b2b16a0e27541580f028ebee5027685a8c397212c43008844be352d3b6acf2269e631bc2c6ba05c2eb95f56fef36'
+ '2c10d4cc6c0b9ca650e786c1e677f22619a78c93465f27fc4cf4831f1cfe771f3b9885a416e381a9e14c3aea5d88cb3545264046188db72d54b8567266811e51')
prepare() {
cd $_pkgname-$pkgver
- # Set known working Electron version
+ # Bump Electron version for newer ABI compatibility
sed 's#\("electron": "\).*"#\16.1.2"#' -i package.json
# Allow higher Node versions
@@ -29,7 +34,7 @@ prepare() {
# Have SQLCipher dynamically link from OpenSSL
# See https://github.com/signalapp/Signal-Desktop/issues/2634
- sed '76s#<.*.a#-lcrypto#;144d' -i node_modules/@journeyapps/sqlcipher/deps/sqlite3.gyp
+ patch -Np0 -i ../openssl-linking.patch
}
build() {
@@ -45,20 +50,18 @@ build() {
package() {
cd $_pkgname-$pkgver
- install -d "$pkgdir"/usr/{bin,lib/$pkgname}
+ install -d "$pkgdir"/usr/{lib,bin}
cp -a release/linux-unpacked/resources "$pkgdir"/usr/lib/$pkgname
- cat << EOF > "$pkgdir"/usr/bin/signal-desktop
+ cat << EOF > "$pkgdir"/usr/bin/$pkgname
#!/bin/sh
-NODE_ENV=production electron /usr/lib/$pkgname/resources/app.asar "\$@"
+NODE_ENV=production electron /usr/lib/$pkgname/app.asar "\$@"
EOF
chmod +x "$pkgdir"/usr/bin/$pkgname
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
-
install -Dm 644 ../$pkgname.desktop -t "$pkgdir"/usr/share/applications
for i in 16 24 32 48 64 128 256 512 1024; do
- install -Dm 644 build/icons/png/${i}* \
+ install -Dm 644 build/icons/png/${i}x${i}.png \
"$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png
done
}