summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Heinrich2018-09-06 21:20:27 +0200
committerJonas Heinrich2018-09-06 21:20:27 +0200
commited5f02e9c179c83c9a8e35730b33c770b1237244 (patch)
tree3d623e844c285abaedfcc6f1b36000f63844c583 /PKGBUILD
downloadaur-ed5f02e9c179c83c9a8e35730b33c770b1237244.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d199645544be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insantiy.org>
+
+pkgname=signal-web-gateway-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="Use Signal as a web gateway for other apps (reporting, monitoring, etc.)"
+arch=('x86_64')
+url="https://gitlab.com/morph027/signal-web-gateway"
+license=('MIT')
+makedepends=('go')
+_gourl=github.com/morph027/textsecure
+
+build() {
+ GOPATH="$srcdir" go get -v ${_gourl}/... # -fix -x
+}
+
+package() {
+ install -Dm755 "$srcdir/bin/azure-storage-azcopy" "$pkgdir/usr/bin/azcopy"
+
+ # Package license (if available)
+ for f in LICENSE COPYING LICENSE.* COPYING.*; do
+ if [ -e "$srcdir/src/$_gourl/$f" ]; then
+ install -Dm644 "$srcdir/src/$_gourl/$f" \
+ "$pkgdir/usr/share/licenses/$pkgname/$f"
+ fi
+ done
+}