summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbl00dy18372021-06-04 12:37:29 +0200
committerbl00dy18372021-06-04 12:37:29 +0200
commit195da6c164b472ed216bb668e7b4d7be5a2b42dd (patch)
tree3209c9aa59ac696d32c4cb7a4076a8c8b740fd2e /PKGBUILD
downloadaur-195da6c164b472ed216bb668e7b4d7be5a2b42dd.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cd9624f22ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: <reg-archlinux AT klein DOT tuxli DOT ch>
+
+pkgname=signus
+pkgver=1.96.0
+pkgrel=1
+pkgdesc="Signus: The Artefact Wars assic turn-based strategy war game similar to the old Battle Isle series."
+arch=('x86_64' 'aarch64')
+url="https://github.com/signus-game/signus"
+license=('GPL2')
+depends=('sdl2' 'sdl2_mixer' 'sdl2_ttf' 'sdl2_image' 'libvorbis' 'libjpeg-turbo')
+source=(
+ "https://github.com/signus-game/signus/archive/refs/tags/v"${pkgver}".tar.gz"
+ "https://github.com/signus-game/signus/commit/e10a6a60489155b4002d7ab186b74adb5dc55046.patch"
+ "https://github.com/signus-game/signus/commit/796f17954613ee60a4c57f3b613618fb347aeecf.patch"
+ "${pkgname}.desktop"
+)
+sha512sums=(
+ '319b2f555f47013d2263ecef6c12751b0f210c052583b943a86bedc4174c5af72495de0d9f2fda578bcd8941b5a7415eb90046b8c8241ce6ebc810fea0e8d756'
+ '82a339e04a5340de3e3f1e47b5833fa9965f6a5cabeba0725642d640500eb86cd6fc4121e750b16d4e13211324ef9fb21298e2df6a44f5b55869a9690b02a00e'
+ '42fcfc39f061819482a54707e55882a65d74b50429940876518dd27bc0351f4239f5fa0848afc875b5d45de88014dcfe820a2ca21f542b16d44f7c59ea9c9015'
+ '6a791044c16bd93f34e8fd77953f310ae645ee0daad5ec4f469247caf9b8665327c3b799b1ac63d8df357255ec85765f4e329c14266232a058f7445775622656'
+)
+conflicts=(${pkgname}-git)
+
+prepare() {
+ patch "${srcdir}/${pkgname}-${pkgver}/signus-data/utils/makedat.cpp" < "${startdir}/e10a6a60489155b4002d7ab186b74adb5dc55046.patch"
+ patch "${srcdir}/${pkgname}-${pkgver}/signus-data/utils/fonts.cpp" < "${startdir}/796f17954613ee60a4c57f3b613618fb347aeecf.patch"
+}
+
+build() {
+ mkdir -p ${srcdir}/${pkgname}-${pkgver}/build
+ #build signus
+ cd "${srcdir}/${pkgname}-${pkgver}/signus"
+ ./bootstrap
+ ./configure --prefix=/usr/
+ make
+ make install DESTDIR=${srcdir}/${pkgname}-${pkgver}/build/
+ #build signus-data
+ cd "${srcdir}/${pkgname}-${pkgver}/signus-data"
+ ./bootstrap
+ ./configure --prefix=/usr/
+ make
+ make install DESTDIR=${srcdir}/${pkgname}-${pkgver}/build/
+}
+
+package() {
+ install -Dm644 "${startdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ cp -rp ${srcdir}/${pkgname}-${pkgver}/build/* ${pkgdir}/
+}