summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2021-06-04 07:13:49 -0400
committerPatrick Northon2021-06-04 07:13:49 -0400
commitd9ddd7875a8e1a305f940d00f015e211094c8c1d (patch)
tree70253b0e388cd401ce77863d39edffa108178e83 /PKGBUILD
parentff1c01fbd3710101447cc9e2c831276cd8eab367 (diff)
downloadaur-sil.tar.gz
Fix compile flags.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1556b0bbdd76..5b3351200258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: metamer <metamer at openmailbox dot org>
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+# Contributor: metamer <metamer at openmailbox dot org>
# Contributor: Michał Walczak <michalwalczak at michalwalczak dot eu>
pkgname=sil
pkgver=1.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="A game of adventure set in the first age of Middle-earth, when the world still rang with elven song and gleamed with dwarven mail. Walk the dark halls of Angband. Slay creatures black and fell. Wrest a shining Silmaril from Morgoth’s iron crown."
arch=('i686' 'x86_64')
url="http://www.amirrorclear.net/flowers/game/sil/"
license=('GPL2' 'custom:angband' 'custom')
depends=('ncurses' 'libx11')
install=sil.install
-source=(http://www.amirrorclear.net/flowers/game/sil/Sil-130-src.zip
+source=("http://www.amirrorclear.net/flowers/game/sil/Sil-130-src.zip"
'sil.sh')
md5sums=('de935f85ab8f9c98d5b781f9ed9e114c'
'97f8ea581605782ef30b4594931d663f')
+prepare() {
+ sed -i 's/CFLAGS = /#CFLAGS = /' "$srcdir/Sil/src/Makefile.std"
+}
+
build() {
cd "$srcdir/Sil/src"
- make -f Makefile.std install
-
- cd ..
+ CFLAGS="$CFLAGS -fcommon -DUSE_X11 -DUSE_GCU" make -f 'Makefile.std' install
}
package() {