summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-02-15 13:18:07 +0200
committerCaleb Maclennan2020-02-16 10:02:30 +0300
commit42a95ed109ae0cb2fa122c34de42b3dbed0be1a9 (patch)
treee0b30a41107e21c434c867d1e5454e636629a600 /PKGBUILD
parentc3025134b11a2e0beadba1398be2cbab4067255d (diff)
downloadaur-42a95ed109ae0cb2fa122c34de42b3dbed0be1a9.tar.gz
Update upstream location, simplify packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 8 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e7da65f7cf7..2c635f3aec07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,8 @@ pkgdesc='Modern typesetting system inspired by TeX'
pkgver=0.10.3
pkgrel=3
arch=('x86_64')
-url='https://www.sile-typesetter.org/'
+url='https://www.sile-typesetter.org'
license=('MIT')
-source=("https://github.com/simoncozens/sile/releases/download/v$pkgver/sile-$pkgver.tar.bz2")
_lua_deps=('cassowary'
'cosmo'
'cliargs'
@@ -26,17 +25,14 @@ _lua_deps=('cassowary'
'zlib')
depends=('fontconfig'
'harfbuzz'
+ 'gentium-plus-font'
'icu'
'lua'
- "${_lua_deps[@]/#/lua-}"
- 'gentium-plus-font')
+ "${_lua_deps[@]/#/lua-}")
checkdepends=('lua-busted')
+source=("https://github.com/sile-typesetter/sile/releases/download/v$pkgver/sile-$pkgver.tar.bz2")
sha256sums=('d89d5ce7d2bf46fb062e5299ffd8b5d821dc3cb3462a0e7c1109edeee111d856')
-prepare () {
- cd "$pkgname-$pkgver"
-}
-
build () {
cd "$pkgname-$pkgver"
./configure --prefix=/usr --with-system-luarocks
@@ -45,17 +41,13 @@ build () {
check () {
cd "$pkgname-$pkgver"
- make busted
+ make busted
}
package () {
cd "$pkgname-$pkgver"
- make install DESTDIR="$pkgdir/"
-
- for file in README.md documentation/sile.pdf ; do
- install -Dm644 "$file" "$pkgdir/usr/share/doc/$pkgname/$(basename "$file")"
- done
+ make install DESTDIR="$pkgdir"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md documentation/sile.pdf
cp -ar examples "$pkgdir/usr/share/doc/$pkgname"
-
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}