summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-05-12 14:09:17 +0300
committerCaleb Maclennan2020-05-12 14:14:14 +0300
commite8553e8191e1160dbb9959e1bf1081f07b78ad66 (patch)
treeb38005016c4c9766d009b5a1fabb1f1d7c816187 /PKGBUILD
parentc0d92233f3e29c61af475b72c7feec38a9500ea3 (diff)
downloadaur-e8553e8191e1160dbb9959e1bf1081f07b78ad66.tar.gz
Add missing library file dependencies
* upgpkg: sile-git 0.10.4.r17.g2c879c9-1 * upgpkg: sile 0.10.4-3 Per Arch wiki, use find-libdeps to scout out libraries we are dynamically linked to after building. Some of the resulting list are not properly provided upstream, but for the ones that are add these as dependencies so that they will be exact version matched. This issue is particularly noticeable with ICU and Harfbuzz which update more frequently. When they do the sile packages break and need rebuilding. This should help flag that as it happens so the breakage isn't unexpected (i.e. throw error during system upgrade rather than leaving sile to crashing on the next invocation).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 24 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 184c76a51ca0..b7b89ab552a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=sile
pkgdesc='Modern typesetting system inspired by TeX'
pkgver=0.10.4
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url='https://www.sile-typesetter.org'
license=('MIT')
@@ -30,27 +30,39 @@ depends=('fontconfig'
'icu'
'libpng' # this goes with libtexpdf if ever split out to a library package
'lua'
- "${_lua_deps[@]/#/lua-}")
+ "${_lua_deps[@]/#/lua-}"
+ 'zlib')
+# Note find via find-deps; needs rebuilding any time versions of these change;
+# currently missing several because parent packages are missing the provides=()
+depends+=('libfreetype.so'
+ 'libharfbuzz.so'
+ 'libicudata.so'
+ 'libicui18n.so'
+ 'libicuio.so'
+ 'libicuuc.so'
+ 'libtexpdf.so')
checkdepends=('lua-busted')
provides=('libtexpdf.so')
source=("https://github.com/sile-typesetter/sile/releases/download/v$pkgver/$pkgname-$pkgver.tar.bz2")
sha256sums=('d136fbe9bc86c3e235d34db170d48af14779c36e8b0b03f542ffdbabcdde4222')
build () {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr --with-system-luarocks
- make all
+ cd "$pkgname-$pkgver"
+ ./configure \
+ --prefix /usr \
+ --with-system-luarocks
+ make all
}
check () {
- cd "$pkgname-$pkgver"
- make busted
+ cd "$pkgname-$pkgver"
+ make busted
}
package () {
- cd "$pkgname-$pkgver"
- make install DESTDIR="$pkgdir"
- install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md documentation/sile.pdf
- cp -ar examples "$pkgdir/usr/share/doc/$pkgname"
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ cd "$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md documentation/sile.pdf
+ cp -ar examples "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}