summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOliver Gasser2018-11-20 13:31:16 +0100
committerOliver Gasser2018-11-20 13:44:43 +0100
commit1f2595e10ef58bc1ae37aefcec28fe64a8d37deb (patch)
tree62341052c0d46d91a9fba31e5ebe4bac12d70736 /PKGBUILD
downloadaur-1f2595e10ef58bc1ae37aefcec28fe64a8d37deb.tar.gz
add silk to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52075d8a21cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Oliver Gasser <oliver@flowriver.net>
+pkgname=silk
+pkgver=3.17.2
+pkgrel=1
+pkgdesc="The System for Internet Level Knowledge (SiLK) is an efficient network flow collection and storage infrastructure that will accept flow data from a variety of sensors. SiLK also provides a suite of efficient command-line tools for analysis."
+arch=('x86_64')
+url="https://tools.netsa.cert.org/silk/index.html"
+license=('GPL')
+source=("https://tools.netsa.cert.org/releases/$pkgname-$pkgver.tar.gz")
+noextract=()
+sha256sums=('70b74eceafce7b724ceccd9e801909f4bd28985406eb8c42a94c8d25e7d58194')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}