summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbrodokk2022-04-25 12:06:34 +0200
committerbrodokk2022-04-25 12:06:34 +0200
commitf9eb651a5e276adce0fc6988bec990ab433c5a9c (patch)
treebd127dc64938c75f644bc5cec31d8a8e2afea895 /PKGBUILD
parentb1ba941c1dfb1a6b00814b976703b3af75acbdf4 (diff)
downloadaur-silkaj.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5734e86f30c7..3e78b5198d91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: neodarz <neodarz at neodarz dot net>
+# Maintainer: brodokk <brodokk at brodokk dot space>
pkgname=silkaj
-pkgver=0.8.1
+pkgver=0.10.0
pkgrel=1
pkgdesc="Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies"
@@ -10,18 +10,17 @@ url='https://git.duniter.org/clients/python/silkaj'
arch=('any')
license=('GPL3')
-depends=('python' 'python-setuptools' 'python-dephell' 'python-click' 'python-ipaddress' 'python-texttable' 'python-tabulate' 'python-pynacl'
+depends=('python' 'python-click' 'python-ipaddress' 'python-texttable' 'python-tabulate' 'python-pynacl'
'python-duniterpy' 'python-pypeg2' 'python-pylibscrypt')
+makedepends=(python-build python-installer python-wheel)
source=("https://git.duniter.org/clients/python/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha512sums=('0ced0aa81da2b56f5178de13c2bbd10923acaf2765b5924493b9169ec5080c9dbf1ae419bcb8837955fbfc86c7f4b22d8365b36351101622b196d4009e6231e5')
+sha512sums=('1e326f1d7b4b916e050615c29b27aaeb96d67199b188f5b164ef3059a6c61aa37afc60533e033ece769981850f6e086e3c09a313d83d565c9eb21054cccf3754')
-prepare() {
- cd "$pkgname-v$pkgver"
- dephell deps convert --from pyproject.toml --to setup.py
+build() {
+ python -m build --wheel --no-isolation
}
package() {
- cd "$pkgname-v$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}